مدیریت و پاکسازی لاگ های اکانتینگ میکروتیک User Manager

با سلام خدمت دوستان عزیز ,ضمن آرزوی سلامتی برای کاربران و دوستان عزیزم ,  مدت ها بود که به دلیل مشغله از بروزرسانی سایت غافل شده بودم و دوستان با ایمیل و نظرات زیادی دلیل آن را جویا شده بودند با عرض پوزش از این دوره که به دلیل درگیری کاری سایت بروز نشد و آموزش های زیادی که در برنامه بود پخش نشد  ولی انشاالله به امید خدا با شروع سال نو برنامه جدیدی برای سایت دارم که به زودی به سمع نظر کاربران عزیزم خواهم رساند .

Mikrotik Routers

Mikrotik Routers

موضوعی که امروز برای توضیح و بحث انتخاب شده است ” مدیریت و پاکسازی لاگ های اکانتینگ Userman یا User Manager میکروتیک ” می باشد .

همانطور که می دانید میکروتیک یک نرم افزار یا پکیج کوچک و کاربردی برای روتر های خود قرار داده که وظیفه اکانتینگ کاربران را بر عهده دارد .

این قسمت میکروتیک در عین حال سادگی بسیار کاربردی بوده و با اینکه خیلی قوی نمی باشد ولی به زبان عامیانه ” کار راه انداز ” می باشد .

Userman فوت و فن های زیادی دارد که در صورتی که رعایت نشود باعث ایجاد مشکل می شود .

در آموزش های بعدی از ابتدا نصب تا پایان آنرا توضیح خواهم داد . اما امروز در این آموزش میخواهیم مبحث لاگ های کاربران که ( Login Faild ها و Success Log و … ) می باشد که باعث پر شدن دیتابیس می شود و در نهایت باعث کندی روتر و یوزر من می شود را بررسی کنیم .

 

برای مطالعه به ادامه مطلب مراجعه نمایید …

خب توجه داشته باشید که در صورتی که سرور شما زود توسط لاگ ها پر می شود لاگ گیری را چک کنید و تیک های مورد نظر را بررسی کنید و سعی کنید لاگ های لازم را تیک بزنید .

 

خب و حالا شروع میکنیم :

 

توجه : هر کدام از این بخش ها به تنهایی زمانبر خواهد بود و ممکن است دقایقی زیادی طول بکشد لذا نیازمند صبر و شکیبایی شما می باشد ….

همچنین قبل از هر تغییری از روتر , یوزر منیجر , کانفیگ و دیتابیس هایتان پشتیبان کامل تهیه نمایید تا در صورت ایجاد اشکالات احتمالی اطلاعات شما پاک نشود .

موفق باشید ”

 

 

 

 

روش اول : روش ساده::::

 

ابتدا این روش را تست کنید در صورتی که مشکلی پیش آمد و نتوانستید آنرا حل کنید روش دوم را با احتیاط انجام دهید .

توجه حتما قبل از هر کاری از دیتابیس هایتان پشتیبان تهیه نمایید . امکان پاک شدن و یا ناقص شدن دیتابیس ها به هر دلیل وجود دارد . 

 

۱- پاکسازی لاگ ها و اطلاعات بدون استفاده :

برای اجرا دستورات ابتدا وارد winbox شوید و از گزینه ها عبارت “New Terminal ” را در پایین پیدا کرده و آنرا باز کنید …

همچنین می توانید از Putty و اتصال با SSH یا Telnet به میکروتیکتان بهره برید :

 

/tool user-manager log remove

خب حالا از شما تعداد سوال میکند که می خواهید کدام خطوط را پاک کنید به عنوان مثال

numbers 1-10000

را بزنید و Enter کنید .

به همین روش ادامه دهید اعداد را تغییر دهید تا تمامی لاگ هایتان  پاک شود …

زمانی که تمام لاگ ها پاک شد … و یا حتی اگر مشکلی داشتید دستور :

tool user-manager database clear-log/

را اجرا کرده و سپس به مرحله بعد بروید .

خطا های احتمالی :

در صورتی که با خطای invalid item number مواجه شدید مقدار عدد آخری ( عدد بزرگ را کم کنید ) …

۲- ساخت و بازنشانی مجدد دیتابیس ها :

/tool user-manager database rebuild

حال با زدن این دستور دیتا بیس باز نشانی شده و سرعت یوزر منیجیر بسیار زیاد می شود .

بعد از اتمام این مرحله روتر را ریبوت کنید .

روش دوم : روش پیچیده و سخت ::::

در صورتی که روش قبلی به شما جواب نداد چاره ای جز این روش ندارید و از این روش هم استفاده نمایید .

ابتدا از دیتابیس هایتان پشتیبان تهیه نمایید و انرا در هارد سیستم خود ذخیره نمایید .

پس از اطمینان شروع کنید :

۱- بک اپ و خروجی گیری از کانفیگ ها :

/tool user-manager export

با زدن دستور بالا خطوط خروجی را که در پنجره Popup باز شده در یک notepad و یا یک ویرایشگر دیگر ذخیره کنید ( توجه کنید بهترین کار استفاده از Notepad++ که کامل ترین ویرایشگر می باشد است … پیشنهاد میکنم قبل از هر کاری آنرا نصب کنید )

دانلود با لینک مستقیم ( Notepad++ 6.9 )

۲- پاک سازی دیتابیس :

/tool user-manager database clear

با زدن دستور بالا دیتابیس پاک سازی میشود

۳-بازنشانی دیتابیس :

/tool user-manager database rebuild

با زدن دستور بالا در ترمینال دیتابیس بازنشانی و بارگزاری مجدد خواهد شد . توجه داشته باشید که این پروسه کمی زمانبر است …

با اتمام این پروسه هارد روتر شما خالی خواهد شد .

بعد از اتمام این مراحل پیشنهاد میکنم خروجی که گرفته بودید و در ویرایشگر کپی کرده بودید را در قسمت کانفیگ Router یا RAS هایتان :

به دنبال عبارت log= بگردید

در صورتی که دوست داشتید میزان آنرا برابر با :

log=”” قرار دهید

یا حداقل log=auth-ok,auth-fail,acct-fail نگذارید … چرا که هر تغییری لاگ گیری شده و میزان مصرف هارد روتر بسیار زیاد خواهد شد .

این بخش را برای هر روتر باید اجرا کنید

در صورتی که مشکلی داشتید میتوانید به بخش روتر ها رفته و به صورت دستی تیک ها را بردارید …  و مطمئن شوید که میکروتیک لاگی برایتان نمیگیرد .

و در پایان میکروتیک را یک بار reboot کنید و تست کنید …

روش سوم : استفاده از اسکریپت ::::

یکی از قابلیت های بسیار خوب میکروتیک استفاده از زبان برنامه نویسی است به طوری که مدیر شبکه می تواند با استفاده از اسکریپت های میکروتیک به هر چیزی که نیاز دارد دست پیدا کند , که بعدا مقاله ای کامل و طولانی از روش ساده یادگیری اسکریپت نویسی منتشر خواهم کرد , اما اسکریپت نویسی ترکیبی از دستورات اصلی میکروتیک و زبان برنامه نویسی سطحی می باشد که به مدیر اجازه هوشمند تر ساختن نیاز خود را می دهد .

برای بهره بری از اسکریپت نویسی در قسمت Tools > Scripts یک اسکریپت جدید بنویسید .

نام را هرچه دوست دارید وارد کنید ….

در بخش اسکریپت مقادیر زیر را وارد کنید :

/tool user-manager session
:foreach i in=[/tool user-manager session find nas-port-type=ethernet] do= {/tool user-manager session remove $i}

و

:local Flag
:set Flag [/tool user-managerlog find]
:if ([:len $Flag] > 0) do={/tool user-manager log print appendfile log;/tool user-manager log remove [/tool user-manager logfind];}

خب حال با زدن این اسکریپت به روتر میگویید تمامی لاگ هایی که port type آن ها بر روی ethernet  می باشند را پاکسازی کند ..

توجه کنید .. حتما هر دو اسکریپت را به صورت جدا اضافه کنید .

به همین راحتی ….

در صورت داشتن هر گونه سوال خوشحال میشوم که با هم به حل آن بپردازیم .

حتی اگر روش بهتری داشتید آنرا بیان کنید چرا که این کار با هزاران روش  امکان پذیر است و من فقط ساده ترین راه ها را بیان کردم تا کاربران عزیزمان خسته یا اذیت نشوند .

با آرزوی موفقیت روز افزون

احمد چوپانی

Incoming search terms:

  • فرنت ویدیو ۲۰۱۶
  • ریست مموری خراب
  • جزوه آموزش میکروتیک
  • آموزش داس
  • اکانتینگ در میکروتیک
  • کانفیگ p2p میکروتیک
  • افزایش تعداد session در یوزر منیجر میکروتیک
  • آموزش یوزر منیجر میکروتیک
  • آموزش گام به گام winbox
  • آموزش نرم افزار winbox pdf
5+

2 پاسخ به مدیریت و پاکسازی لاگ های اکانتینگ میکروتیک User Manager

  1. […] شده و سرعت یوزر منیجیر بسیار زیاد می شود . منبع : مدیریت و پاکسازی لاگ های اکانتینگ میکروتیک User Manager | وبس… پاسخ با نقل […]

    0
  2. […] مدیریت و پاکسازی لاگ های اکانتینگ میکروتیک User Manager … […]

    0

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *